Netiquette · Download · News · Gallery · Homepage · DSSR Manual · G-quadruplexes · DSSR-Jmol · DSSR-PyMOL · DSSR Licensing · Video Overview· RNA Covers

Author Topic: setting path for 3DNA in linux  (Read 15159 times)

Offline bala

  • with-posts
  • *
  • Posts: 9
    • View Profile
setting path for 3DNA in linux
« on: February 13, 2007, 03:59:51 am »
Hello,

First of all, i would like to thank the authors for such a useful program.  

I am using 3DNA in Red hat enterprise Linux 3.0.  I downloaded the software and installed in /usr/local.  When i unzip and untar the file, it created a directory called X3DNA.

so my path is /usr/local/X3DNA.  Then i set an enviroment variable as follows in my .bashrc file.

export X3DNA=/usr/local/X3DNA/
export PATH=$PATH:$X3DNA/bin

Howver, when i run  any executable, say find_pair, it says command not found and hence every time i am copying my pdb file /usr/local/X3DNA and run the program. Why is it so.  Kindly suggest me something.  Is is because the environmental variable name and the directory name are the same.

Bala

Offline xiangjun

  • Administrator
  • with-posts
  • *****
  • Posts: 1640
    • View Profile
    • 3DNA homepage
(No subject)
« Reply #1 on: February 13, 2007, 08:13:08 pm »
Hi,

Thanks for using 3DNA.

What happens if you do the following?

Code: [Select]
which find_pair
source ~/.bashrc
which find_pair


In other words, I suspect your setting is not in effect yet before running the source command, or starting another shell.

HTH,

Xiang-Jun

Offline bala

  • with-posts
  • *
  • Posts: 9
    • View Profile
(No subject)
« Reply #2 on: February 22, 2007, 01:50:29 am »
Hello xiangjun,

Sorry for the delayed reply. I was on leave.

I have installed the sofware in /usr/local/X3DNA

I have set the following path in .bashrc file

export X3DNA=/usr/local/X3DNA/
export PATH=$PATH:$X3DNA/bin

When i give "which find_pair" as you suggestted, i got the following big message.


/usr/bin/which: no find_pair in (/usr/local/autodock/share/bin:/usr/local/autodock/i86Linux2/bin:
/usr/local/ifc/bin:/usr/local/autodock/share/bin:/usr/local/autodock/i86Linux2/bin:
/usr/local/ifc/bin:/usr/local/autodock/share/bin:/usr/local/autodock/i86Linux2/bin:
/usr/local/ifc/bin:/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:
/usr/local/amber8/exe:/usr/local/pass:/usr/local/nab-5.0/bin://usr/local/grace/bin:
/usr/local/mmtsb_toolset/perl:/usr/local/mmtsb_toolset/bin:/usr/local/X3DNA//bin:
/home/madhu/bin:/usr/local/amber8/exe:/usr/local/pass:/usr/local/nab-5.0/bin:
//usr/local/grace/bin:/usr/local/mmtsb_toolset/perl:/usr/local/mmtsb_toolset/bin:
/usr/local/X3DNA//bin:/usr/local/amber8/exe:/usr/local/pass:/usr/local/nab-5.0/bin:
//usr/local/grace/bin:/usr/local/mmtsb_toolset/perl:/usr/local/mmtsb_toolset/bin:
/usr/local/X3DNA//bin)

Offline xiangjun

  • Administrator
  • with-posts
  • *****
  • Posts: 1640
    • View Profile
    • 3DNA homepage
(No subject)
« Reply #3 on: February 22, 2007, 10:42:38 pm »
Hi,

Life should not be that hard! Setting up the 3DNA environment has rarely been an issue, indeed yours is the first case I've come cross over the past few years.

I noticed that you set X3DNA as
Code: [Select]
export X3DNA=/usr/local/X3DNA/i.e., with a trailing '/'. In the output error message, you have path
Code: [Select]
/usr/local/X3DNA//binNoticed the two '//' between X3DNA and bin? The error message means you have not put 3DNA bin directory into your command line search path yet.

Try the following in your current terminal, one line at a time, what did you get?
Code: [Select]
echo $SHELL
       # do you get '/bin/bash'? -- verifies you have 'bash' shell
ls /usr/local/X3DNA/bin/find_pair
       # this verifies that you indeed installed 3DNA under /usr/local
export X3DNA=/usr/local/X3DNA
       # without trailing '/'
echo $X3DNA
ls $X3DNA/bin/find_pair
       # If 3DNA is installed under /usr/local, this should print the full path
export PATH=$PATH:$X3DNA/bin
which find_pair


Please report back how it goes.

Xiang-Jun

Offline bala

  • with-posts
  • *
  • Posts: 9
    • View Profile
(No subject)
« Reply #4 on: February 24, 2007, 01:21:28 am »
Hi,
Thank You.  I gave the commands one by one as you suggested and i have pasted below what i got.

echo $SHELL
/bin/bash

ls /usr/local/X3DNA/bin/find_pair
ls: /usr/local/X3DNA/bin/find_pair: Permission denied

export X3DNA=/usr/local/X3DNA
echo $X3DNA
/usr/local/X3DNA

ls $X3DNA/bin/find_pair
ls: /usr/local/X3DNA/bin/find_pair: Permission denied

export PATH=$PATH:$X3DNA/bin

which find_pair
alias find_pair='/usr/local/X3DNA/bin/find_pair'


Finally i gave "find_pair" in the shell prompt and it throwed following message.

bash: /usr/local/X3DNA/bin/find_pair: Permission denied

Offline xiangjun

  • Administrator
  • with-posts
  • *****
  • Posts: 1640
    • View Profile
    • 3DNA homepage
(No subject)
« Reply #5 on: February 24, 2007, 11:37:56 am »
Then it is clear that you do not have permission set up correctly for $X3DNA/bin executables. I do not know your level of Linux/Unix, and/or access right to the /usr/local directory. But you can try the following:

Code: [Select]
export X3DNA=/usr/local/X3DNA
export PATH=$PATH:$X3DNA/bin
chmod a+rx /usr/local/X3DNA/bin/*
find_pair


Other than that, you need to consult your system administrator or local Linux/Unix expert for help.

Alternatively, you can always install 3DNA under your home directory.

HTH,

Xiang-Jun

 

Created and maintained by Dr. Xiang-Jun Lu [律祥俊] (xiangjun@x3dna.org)
The Bussemaker Laboratory at the Department of Biological Sciences, Columbia University.