3DNA Forum

Questions and answers => MD simulations => Topic started by: bciezah1 on March 17, 2017, 07:15:59 pm

Netiquette · Download · News · Gallery · Homepage · DSSR Manual · G-quadruplexes · DSSR-Jmol · DSSR-PyMOL · DSSR Download/Licensing · {Video Overview of DSSR}

Title: "Ruby in cygwin"
Post by: bciezah1 on March 17, 2017, 07:15:59 pm
Hello! My name is Basilio

I am trying to use 3DNA to analyze some MD data. I tried to do it with x3dna v2.0 (32) but it seems that this option is available just in x3dna v2.3....however, when I tried to install this in cygwin64...everything was ok till the computer told me that the problem is 'RUBY' I tried to install it but I did not find how to install ruby in cygwin64.... i really will appreciate your advice

Thank you,

Basilio.
Title: Re: "Ruby in cygwin"
Post by: xiangjun on March 17, 2017, 07:43:42 pm
Hi,

Welcome back. Did you solve the installation problem reported in another thread (http://forum.x3dna.org/general-discussions/'running-3dna-in-cygwin64'/)? Please follow up over there for the benefit of other users.

Ruby installation is easy with Ruby Installer (https://rubyinstaller.org) in Windows, and it is accessible in Cygwin.

Thanks,

Xiang-Jun
Title: Re: "Ruby in cygwin"
Post by: bciezah1 on April 05, 2017, 10:36:41 am
Hello Xiang-Jun,

I am trying to install the last version of 3DNA(V2.3) in my computer, but I have a problem. My computer is window 10, I am using cygwin. Firstly, I installed ruby using the link you suggested (https://rubyinstaller.org/downloads/) Then I went to the web to download 3DNA v2.3. I download the x3dna-v2.3-mingw-win.tar.gz version. And I followed your advices:

tar pzxvf x3dna-v2.3-linux-64bit.tar.gz
Here the options pzxvf require some explanation:

    p to preserve permissions of the various directories and files. This option may not be required for a personal setting.
    z filter the archive through gzip. With this option, we can work directly from .tar.gz file without first using gunzip.
    x to extract files from an archive.
    v to verbosely list files processed.
    f to use archive file, i.e., the 3DNA tarball file x3dna-v2.3-linux-64bit.tar.gz.

After running the above command, you will get a directory named x3dna-v2.3 which contains the 3DNA v2.3 distribution.
cd x3dna-v2.3/bin
enter into the bin directory of the 3DNA v2.3 distribution.
./x3dna_setup

However, when I ran the last command I got the next error message:

/usr/bin/env: ‘ruby’: No such file or directory

But I just installed ruby.

Just in case, I download the linux version (x3dna-v2.3-linux-64bit.tar.gz) and I tried to install it in cygwin....but I got the same message. I will appreciate your advice,

Thank you,

Basilio.
Title: Re: "Ruby in cygwin"
Post by: bciezah1 on April 06, 2017, 10:59:33 am
Hello

I just installed the new version! I installed the bash on linux on window. Then i installed there ruby and finally 3DNA! Thank you!

Basilio.

Created and maintained by Dr. Xiang-Jun Lu [律祥俊] (xiangjun@x3dna.org)
The Bussemaker Laboratory at the Department of Biological Sciences, Columbia University.